VC6 builds but won't Debug - "binary was not built with debug information"

May 16, 2016 at 4:28 PM
When I upgraded to Windows 10 last week I was pleased to find that the existing installation of VS6 did seem to work. That's to say it did build [1]. However on trying to debug something I found that although my application would run in the VC6 debugger, if I had a breakpoint it would break but not then be able to resume, or single step; all of these resulting in an "Access Violation" error (possibly followed by "Privileged Instruction").
I was very interested to find Daffodil, which I have installed and has allowed me to build my project using VC2013 with the VS6 tools. However, on attempting to run the project in the debugger I am being told "binary was not built with debug information".
I wonder if anyone else has had this working ? Or is there something incompatible between VS2013's debugger implementation and VC6's debug information ? Or have I just missed some configuration somewhere ? Or has Daffodil missed setting something ?

[1] It was on Win 7, which worked perfectly except for an issue where a process being debugged couldn't properly be stopped by the debugger (eg using shift-F5), leaving an orphaned process if that was tried, and needed to be stopped using Process Explorer.
May 16, 2016 at 4:36 PM
Did you see this?
May 16, 2016 at 4:37 PM
Ok, seems I should have looked a little further through these discussions. It looks like it's already answered.

for VS2013:
Enable "Native Edit and Continue"
under Tools->Options->Debugging->Edit and Continue

Mine seems to be fixed by this.