My first time to try Daffodil and need help

Mar 1, 2012 at 9:02 PM

I use the following compilers

- VC6 SP6

- VC2005 SP1

- VC2010 SP1

I also develop on the following platforms

- Win XP SP3

- Win 7 (32bit)

- Win 7 (64bit)

I just installed daffodil and is going to open a VC6 project (test.dsw).

[1] How do I open it?  I can do one of the following ways.

- By double-clicking test.dsw directly

- By opening VC2010 first and then File-Open-Project/Solution

- By dragging test.dsw into the VC2010 Quick launch icon

- etc

Which one is the best way to go?

[2] For your reference, when I open an existing vc2010 project which was originally created by VC2010, I  see there are three platforms to choose.

- vc100

- vc90

- vc80

But I don't see no vc60.  Is this correct?

[3] How do I attach a file, for example, test.dsw and/or test.dsp?

 

 

Coordinator
Mar 1, 2012 at 9:35 PM

1) It doesn't matter how you open the file, as long as you open it in VS 2010 so that it can migrate the original project automatically for you. Or of course you can recreate the project from scratch in VS 2010.

2) If Daffodil is installed, you should see Platform Toolsets listed for all supported platforms: v100, v90, v80, v71, v70, and v60. If you don't see those listed, then either you have not exited all instances of Visual Studio and restarted, or Daffodil is not correctly installed.

3) I don't know, it may not be possible here.

 

Mar 1, 2012 at 11:40 PM
> 2) If Daffodil is installed, you should see Platform Toolsets listed for all
> supported platforms: v100, v90, v80, v71, v70, and v60. If you don't see
> those listed, then either you have not exited all instances of Visual Studio
> and restarted, or Daffodil is not correctly installed.

=> Thinking back, I installed Daffodil while VC6, VC2005, and VC2010
were running.
I guess my Daffodil install got messed up.
So, I removed Daffodil and reinstalled it after closing all VC instances.
Then I opened an existing VC2010 sln file and still see vc100, vc90,
and vc80 only.
How can I fix this situation to add vc60 please?

thx
HR
Coordinator
Mar 1, 2012 at 11:54 PM

VS 2010 installs v100 and v90. You say you see vc100, vc90, and vc80. I don't know if you mistyped the names, but in any case, it sounds like you have either made changes manually or installed something else that has changed your settings. You should undo whatever other changes you made previously. If Daffodil installed correctly and the files are where they are supposed to be, then what you describe would indicate that you changed the MSBuildExtensions32 path. I don't know if repairing your VS 2010 install will fix this, but it might.

Mar 2, 2012 at 12:02 AM
> VS 2010 installs v100 and v90. You say you see vc100, vc90, and vc80. I
=> This means that opening pure VC2010 solution after installing
Daffodil should show vc100 and vc90 but not vc80?

For testing if I can work with an old VC6 project (test.dsw), I opened
VC2010 first and then opened the test.dsw. VC2010 automatically
converted the test.dsw to test.sln and now I see all vc100, vc90,
vc80, vc71, vc70, and vc60.
=> Is this correct?

HR
Coordinator
Mar 2, 2012 at 12:45 AM

You still mistype the names, but it sounds correct.